We’re pleased to release v0.1.2-Beta.3 of Exchange Analyzer.

This release contains no new tests, however it does contain an overhauled report format that we’re hoping will be more readable and useful. Please try it and let us know what you think.

If you’re updating from a previous build please be sure to copy the new version of the ExchangeAnalyzer module to your PowerShell modules folder.

Now that we’re getting closer to a good underlying framework we’ll be able to turn more of our attention to developing new tests for the analyzer. We’ve got lots of new test in the works already, and plan to have several of them included in the next release.

Here’s the list of what’s new and fixed in v0.1.2-Beta.3:

  • New test outcomes of “Info” and “Warning”, with existing tests updated to handle this change
  • New report format and multiple minor tweaks for improved readability
  • Default report file name now contains date and time for uniqueness
  • A new -FileName parameter added to allow you to specify your own report file name and path
  • Fixed $ExchangeServers variable to exclude unsupported server versions
  • Fixed “Method invocation failed” error due to Exchange 2013 vs 2016 Get-ExchangeServer cmdlet behavior

Download Exchange Analyzer from the TechNet Script Gallery.

Feedback and bug reports welcome on GitHub or by emailing emailing feedback@exchangeanalyzer.com.

About the Author

Paul Cunningham

Paul is a former Microsoft MVP for Office Apps and Services. He works as a consultant, writer, and trainer specializing in Office 365 and Exchange Server. Paul no longer writes for Practical365.com.

Comments

  1. Admin

    Hello. We ran this in an environment that has two different Exchange sites (2013) and also had previous Exchange 2010 environment coexisting. The only error we received was “One or more Exchange sites has more than one namespace per HTTPS protocol.” Can you provide the query that you use for this check, and or provide guidance on how to find the setting that is out of place, triggering this alert. By design, we should only be using one namespace https://mail.company.com. We’re a medium environment that uses just about every feature of Exchange, and aside from this report, there’s no indication of anything not functioning correctly. We just want to ensure we’re fully healthy. Thanks

    1. Paul Cunningham

      Look at the CAS namespace summary tables. Do you see any namespaces that don’t match what you’re expecting to see? The usual culprit here is the MAPI virtual directory, which people often leave un-configured because they aren’t planning to use MAPI/HTTP yet.

Leave a Reply